程序设计基础29 图的最短路径(一)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

一,注意事项:

    使用Dijsktra算法之前一定要注意初始化,题目中有什么指标就对什么初始化,所有的都要先对距离(或花费cost[max_n]等)dis[max_n]等初始化,还要对第二指标路径的数目num[max_n],还有救援人员的人数amount[start]=single[start],当初就忘了对这个进行初始化。

#include<cstdio>
#include<algorithm>
using namespace std;
const int INF = 1000000000;
const int max_n = 550;
int N = 0;
int G[max_n][max_n] = { 0 };
int dis[max_n] = { 0 };
int num[max_n] = { 0 };
int amount[max_n] = { 0 };
int single[max_n] = { 0 };
bool vis[max_n] = { false };
void Dijkstra(int start) {
	fill(dis, dis + max_n, INF);
	dis[start] = 0;
	num[start] = 1;
	amount[start] = single[start];
	for (int i = 0; i < N; i++) {
		int MIN = INF, u = -1;
		for (int j = 0; j < N; j++) {
			if (dis[j] < MIN&&vis[j] == false) {
				u = j;
				MIN = dis[j];
			}
		}
		if (u == -1)return;
		vis[u] = true;
		for (int j = 0; j < N; j++) {
			if (vis[j] == false && G[u][j] != 0) {
				if (dis[u] + G[u][j] < dis[j]) {
					dis[j] = dis[u] + G[u][j];
					amount[j] = amount[u] + single[j];
					num[j] = num[u];
				}
				else if (dis[u] + G[u][j] == dis[j]) {
					num[j] += num[u];
					if (amount[u] + single[j] > amount[j]) {
						amount[j] = amount[u] + single[j];
					}
				}
			}
		}
	}
}
int main() {
	int M = 0;
	int c1 = 0, c2 = 0;
	int x = 0, y = 0, z = 0;
	scanf("%d %d %d %d", &N, &M, &c1, &c2);
	for (int i = 0; i < N; i++) {
		scanf("%d", &single[i]);
	}
	for (int i = 0; i < M; i++) {
		scanf("%d %d %d", &x, &y, &z);
		G[x][y] = z;
		G[y][x] = z;
	}
	Dijkstra(c1);
	printf("%d %d", num[c2], amount[c2]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82927010