Discovering Gold LightOJ - 1030

LightOJ - 1030 

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题意:1*N的方格,知道每一个方格的宝藏价值,用抛色子的方法前进,如果你的新位置是在洞外,那么你继续扔,直到你得到一个合适的结果。能得到的宝藏总和的数学期望

题解:简单概率dp

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
//#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int O    =  1e5;
const int MOD  =  1e4+7;
const int maxn =  1e2+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

int main()
{
    int T;scanf("%d",&T);
    int l = 0;
    while(T--)
    {
        int n;scanf("%d",&n);
        int a[maxn];MT(a,0);
        for(int i=n-1;i>=0;i--) scanf("%d",&a[i]);
        printf("Case %d: ",++l);
        double dp[maxn];  dp[0] = a[0];
        for(int i=1;i<n;i++)
        {
            dp[i] = a[i];
            if(i>=6) for(int j=1;j<=6;j++) dp[i] += dp[i-j]/6;
            else for(int j=1;j<=i;j++) dp[i] += dp[i-j]/i;
        }
        printf("%.7f\n",dp[n-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/82656128