期望DP——F - Discovering Gold LightOJ - 1030

博客目录

一、原题

题目传送门(vjudge,有密码)

题目传送门(lightoj)

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. Theith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

二、题目大意

有一排n个房间,每个房间里都有ai数量的金子,现在你站在第1个房间,只能往前走,现在你开始抛骰子,骰子是几就往前走几个房间,进入房间后就得到了这个房间的金子。如果骰子的数值加当前的位置大于n(越界),则重新投掷。问得到的金子数量的期望。

三、分析

比较基础的期望题。期望从后往前推

  • 设dp[i]表示从i到n所期望得到的金子数量
  • 递推公式(考虑中间情况假设不在边界上):dp[i]=dp[i-1]*1/6+dp[i-2]*1/6+...+dp[i-6]*1/6
  • 边界:当走到最后6个房间,要改变公式和概率
  • 如果讲的不清楚就看代码吧

四、AC代码

#include<bits/stdc++.h>
using namespace std;
double dp[1005];
int main()
{
	int T;
	cin>>T;
	int i,j;
	int len;
	int cs=1;
	while(T--)
	{
		int n;
		cin>>n;
		for(i=1;i<=n;i++)
		{
			scanf("%lf",&dp[i]);
		}
		for(i=n-1;i>=1;i--)
		{
			len=min(6,n-i);
			for(j=1;j<=len;j++)
			{
				dp[i]+=dp[i+j]/len;
			}
		}
		printf("Case %d: %.9lf\n",cs++,dp[1]);
	}
}


猜你喜欢

转载自blog.csdn.net/greybtfly/article/details/80551344