Java练习 SDUT-2504_多项式求和

多项式求和

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

多项式描述如下:
1 - 1/2 + 1/3 - 1/4 + 1/5 - 1/6 ……
先请你求出多项式前n项的和。

Input

第一行输入一个数T代表测试数据个数(T<=1000)。接下来T行每行1个数代表n(0<=n< 2^31)。

Output

对于每个输入样例,输出多项式和的结果(结果精确到小数点后两位)。每行输出一个结果。

Sample Input

2
1
2

Sample Output

1.00
0.50

Hint

Source

中国海洋大学第三届“朗讯杯”编程比赛高级组试题

这道题数据量特别大,如果头铁硬算基本都会超时,答案精确到小数点后两位,当n到达一定大小时就不会在影响结果。
打表可以得到在270左右就不会再变,保险起见取300,即

if(n>=300)
    n = 300;

其他的正常计算就好。

import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int t,i,n,k;
        double sum;
        t = cin.nextInt();
        while(t-->0)
        {
            k = 1;
            n = cin.nextInt();
            if(n>=300)
                n = 300;
            sum = 0;
            for(i=1;i<=n;i++)
            {
                sum += 1 / (double)i * k;
                k = -k;
            }
            System.out.printf("%.2f\n",sum);
        }
        cin.close();
    }

}

猜你喜欢

转载自www.cnblogs.com/luoxiaoyi/p/9712816.html