[kuangbin带你飞]专题四 最短路练习 D - Silver Cow Party

POJ - 3268

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

#include <iostream>
#include <cstring>
#include <algorithm>
#define inf 99999999
using namespace std;

int n,m,x;
int map[1010][1010];
int vis[1010],d[1010],p[1010];


void dij()
{
	int v;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	{
		d[i]=map[x][i];
		p[i]=map[i][x];
	}
	for(int i=1;i<=n;i++)//过去 
	{  
        int minn=inf;
        for(int j=1;j<=n;j++)  
            if(!vis[j]&&d[j]<minn)
			{
                v=j;  
                minn=d[j];
            } 
        vis[v]=1;
        for(int j=1;j<=n;j++)  
            if(!vis[j]&&d[j]>map[v][j]+d[v])  
			    d[j]=map[v][j]+d[v];  
    }
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)//回来 
	{  
        int minn=inf;
        for(int j=1;j<=n;j++)  
            if(!vis[j]&&p[j]<minn)
			{
                v=j;
                minn=p[j];
            } 
        vis[v]=1;
        for(int j=1;j<=n;j++)  
            if(!vis[j]&&p[j]>map[j][v]+p[v])  
			    p[j]=map[j][v]+p[v]; 
    }
}

int main()
{
	scanf("%d%d%d",&n,&m,&x);
	for(int i=1;i<=n;i++)
	    for(int j=1;j<=n;j++)
	        if(i==j)map[i][j]=0;
	        else map[i][j]=inf;
	for(int i=0;i<m;i++)
	{
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		map[a][b]=c;
	}
	dij();
	for(int i=1;i<=n;i++)d[i]+=p[i];
	sort(d+1,d+1+n);
	cout<<d[n]<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/81297392