PAT甲级1009 多项式相乘

题目

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6


题解

#include<iostream>
using namespace std;
int main(){
  int k,m,n;
  int cnt=0;
  double a;
  double c[2001]={0.0},p[1001]={0.0};
  scanf("%d",&k);
  for(int i=0;i<k;i++){
    scanf("%d %lf",&n,&a);
    p[n]=a;
  }
  scanf("%d",&m);
  for(int i=0;i<m;i++){
    scanf("%d %lf",&n,&a);
    for(int j=0;j<1001;j++){
      c[j+n]+=p[j] * a;//特别想说这个的j不是指第一行的对数,是指数出现的情况数
      
    }
  }
  
  for(int i=0;i<2001;i++){
    if(c[i]!=0.0) cnt++;
  }
  printf("%d",cnt);
  for(int i=2000;i>=0;i--){
    if(c[i]!=0.0) printf(" %d %0.1f",i,c[i]);
  }
  
  return 0;
}

怎么说呢,我一开始不很理解交叉相乘怎么操作。其实一般都是固定一行作为外层循环,然后内层遍历另一行的所有情况。这里的所有情况不是指输入的对数,而是参数的可能性的范围。这里指数是主要考虑参数,所以循环从0到1000。

还有一点要关注的是,用double还是float的问题。其实是都可以的~

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82779848