HDU1241: DFS(深搜)

HUD1241: Oil Deposits

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2
这道题大概意思就是,输入两个数代表行和列,其中”@”代表有油,“*”代表没有油,而一个油周围8个方位假如有油,则看成是同一个油矿,最后输出图中有多少的油矿

#include<iostream>
using namespace std;

int N,M;  //代表行和列
char map[109][109]; //存储地图

int dp[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
//代表周围八个方向

//深搜
void find(int x,int y)
{
    for(int i=0;i<8;i++)//分别走八个方向
    {
        int nx=x+dp[i][0];  //列更新
        int ny=y+dp[i][1];  //行更新

        if(nx<N&&nx>=0&&ny>=0&&ny<M)  //判断是否越界
        if(map[nx][ny]=='@')   //判断更新后是否有油
        {
            map[nx][ny]='*';  //将有油变为没油,防止重复
            find(nx,ny);
        }
    }
}

int main()
{
    while(cin>>N>>M&&N&&M) 
    {

        int sum=0; //油矿数目

        for(int i=0;i<N;i++)
        {
            cin>>map[i];
        }

        //寻找有油的地方,变为没有,进入深搜
        //深搜的过程就是去找周围八个方向,在不越界的情况下,在有油时,则进入下一次递归,没有油则继续查找
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<M;j++)
            {
                if(map[i][j]=='@')
                {
                    map[i][j]='*';
                    find(i,j);
                    sum++;
                }
            }
        }
        cout<<sum<<endl;
    }
} 

猜你喜欢

转载自blog.csdn.net/dome_1720/article/details/82633497