HDU - 1241 ,BFS,DFS

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

我用了两种搜索都写了一边,

思路就是找到@然后搜他的4周(这回是8个地方都要搜一下,)然后让@变成*,直到四周都是*停止,连通的@算一个大油田,每次搜结束,油田+1

DFS

#include<queue>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char map[105][105];
int n,m;

int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int dfs(int x,int y){
	int dx;
	int dy;
	
	for(int i=0;i<8;i++)
	{
		dx=x+dir[i][0];
		dy=y+dir[i][1];
		if(map[dx][dy]=='@'&&dx>=1&&dx<=n&&dy>=1&&dy<=m)
		{
			map[dx][dy]='*';
			dfs(dx,dy);
			
		}
	}
	
	return 0;
}
int main()
{
	
	while(cin>>n>>m)
	{
		if(m==0&&n==0)
		break;
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			cin>>map[i][j];
		int ans=0;

		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			if(map[i][j]=='@')
			{
				map[i][j]='*';
				dfs(i,j);
				ans++;
			}
		}
		cout<<ans<<endl;
	}
	
	return 0;
}

BFS


#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char map[101][101];
int to[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};
struct node{
	int x,y;
};
int m,n;
void bfs(int x,int y){
	queue<node> q;
	node now,next;
	now.x=x;
	now.y=y;
	q.push(now);
	while(!q.empty())
	{
		node front;
		front=q.front();
		q.pop();
		for(int i=0;i<8;i++)
		{
			next.x=front.x+to[i][0];
			next.y=front.y+to[i][1];
			if(map[next.x][next.y]=='@')
			{	
				map[next.x][next.y]='*';
				q.push(next);
			}
		}
	}
	
	
}
int main(){
	
	
	memset(map,'\0',sizeof(map));
	while(cin>>m>>n)
	{   
	
			if(m==0&&n==0)
			break;
			for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				cin>>map[i][j];
			}
			int ans=0;
			for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					ans++;
					map[i][j]='*';
					bfs(i,j);
				}
			}
		cout <<ans<<endl;
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42627450/article/details/81136711