1044 火星数字(map+打表)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

思路:

  1. 由于数据范围不大(13*13-1),使用打表比模拟要简单的多
  2. 只有当个位数和十位数均不为0时,火星文是由两个字符串拼接而成
  3. 数转字符串用数组,字符串转数用map
#include<cstdio>
#include<iostream>
#include<map>
#include<string>
using namespace std;
string unitDigit[13]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string tenDigit[13]={"tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string numToStr[170];
map<string,int> strToNum;

void init(){
    for(int i=0;i<13;i++){
        numToStr[i]=unitDigit[i];//gewei 0
        strToNum[unitDigit[i]]=i;
        numToStr[i*13]=tenDigit[i];//shiwei 0
        strToNum[tenDigit[i]]=i*13;
    }
    for(int i=1;i<13;i++){//geshiweidoubuwei 0 
        for(int j=1;j<13;j++){
            string str=tenDigit[i]+" "+unitDigit[j];
            numToStr[i*13+j]=str;
            strToNum[str]=13*i+j;
        }
    }
}

int main(){
    int n;
    scanf("%d%*c",&n);//tiaoguogaishuruzhi 
    init();
    while(n--){
        string temp;
        getline(cin,temp);
        if(temp[0]>='0'&&temp[0]<='9'){
            int num=0;
            for(int i=0;i<temp.length();i++){
                num=num*10+temp[i]-'0';
            }
            cout<<numToStr[num]<<endl;
        }else{
            cout<<strToNum[temp]<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/exciting/p/10352404.html