刘志梅201771010115.《面向对象程序设计(java)》第三周学习总结

实验三 Java基本程序设计(2

实验时间 2018-9-13

1、实验目的与要求

1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

2)熟悉PTA平台线上测试环境;

3)掌握Java语言构造基本程序语法知识(ch1-ch3)

4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

理论知识概括:JAVA 的五种语句:(1)方法调用语句(2)表达式语句(3)复合语句(4)控制语句(5)package语句

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

实验2-实验3在课后完成

实验2公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证的年月日抽取出来,按年-月-日格式输出。注意:输入使用ScannernextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

package c;

import java.util.Scanner;

public class A {

    public static void main(String[] args) {

        // TODO Auto-generated method stub

        Scanner in= new Scanner(System.in);

        System.out.println("请输入身份证号码");

        String num = in.nextLine();

        int len =num.length();

        if(len<18||len>18)

        System.out.println("输入错误");

        else

        {

        int i = 6;

        String year = num.substring(i, i+4);

        String month = num.substring(i+4, i+6);

        String day = num.substring(i+6, i+8);

        

        System.out.println(year+"-"+month+"-"+day);}

    }

}

实验3studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

package d;

  import java.io.BufferedReader;

   import java.io.File;

   import java.io.FileReader;

  import java.io.IOException;

 import java.util.ArrayList;

  import java.util.Scanner;

  

  public class D {

      private static ArrayList<Student>studentList  = null;

      public static void StudentsFromFile(String fileName){

        

          File file = new File(fileName);  

          BufferedReader reader = null;  

          try {  

              reader = new BufferedReader(new FileReader(file));  

              String tempString = null;  

              while ((tempString = reader.readLine()) != null) {  

                  String str[] = tempString.split(" ");

                if(studentList!= null && str.length > 1) {

                    //Object studentId;

                    Student student = new Student();

                     student.setStudentId(str[0]);

                    student.setName(str[1]);

                    studentList.add(student);

                 }

              }  

              reader.close();  

          } catch (IOException e) {  

             e.printStackTrace();  

         } finally {  

              if (reader != null) {  

                  try {  

                      reader.close();  

                  } catch (IOException e1) {  

                  }  

              }  

          }

      }

     public static String findStudentIdByName(String name) {

          String studentId = null;

          for(Student student : studentList) {

              if(student.getName().equals(name)) {

                  studentId = student.getStudentId();

                  break;

              }

          }

          return studentId;

      }

      public static String findStudentNameById(String ID) {

          String studentName = null;

          for(Student student : studentList) {

              if(student.getStudentId().equals(ID)) {

                  studentName = student.getName();

                  break;

              }

          }

          return studentName;

      }

      public static void main(String args[]) {

          String path = "C:\\Users\\Dell\\Documents\\Tencent Files\\1689164469\\FileRecv\\实验三/studentfile.txt";

        studentList = new ArrayList<Student>();

          StudentsFromFile(path);

          int statu = 1;

          System.out.println();

          while(statu != 0) {

              System.out.println("******************");

              System.out.println("1:通过姓名查询学生学号");

              System.out.println("2:通过学号查询学生姓名");

             System.out.println("0:退出");

              System.out.println("******************");

              Scanner in = new Scanner(System.in);

              statu = in.nextInt();

             

              switch(statu) {

              case 1:{                  System.out.println("请输入学生姓名:");

                 Scanner scanner1 = new Scanner(System.in);

                  String name = scanner1.nextLine();

                  String Id = findStudentIdByName(name);

                  if(Id != null) {

                      System.out.println("姓名: "+name+" 学号: "+Id);

                  }else {

                      System.out.println("不存在该学生!请重新查找");

                  }

  

              }break;

              case 2:{

                  System.out.println("请输入学生学号:");

                  Scanner scanner2 = new Scanner(System.in);

                  String Id = scanner2.nextLine();

                  String name = findStudentNameById(Id);

                  if(name != null) {

                      System.out.println("姓名: "+name+" 学号: "+Id);

                 }else {

                     System.out.println("不存在该学生!请重新查找");

                 }

             }break;

             case 0:

                 statu = 0; break;

             default:

                 System.out.println("输入错误");

             }

          }     

          System.out.println("byebye!");

      }

    

   }

 

总结:通过本次实验发现程序编写有很多困难,程序在eclipse上运行不出结果,在编写过程中,出现了很多错误并且不能独立完成。在第二个实验时,编写过程没有头绪,不知道该怎么编写; 通次这次的作业发现自己编写能力很不好很差,感觉自己好多不会,需要好好练习加以进步;好好学习课本内容并积极向其他同学学习(在实验编写过程中找不出问题所在)。

猜你喜欢

转载自www.cnblogs.com/LZM7343/p/9657418.html