201771010110孔维滢《面向对象程序设计(java)》第三周学习总结

一. 1-3章内容复习

二. 实验三

1、实验目的与要求

(1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

(2)熟悉PTA平台线上测试环境;

(3)掌握Java语言构造基本程序语法知识(ch1-ch3);

(4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/,使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

             编程题2改正:

mport java.util.*;
public class DayMonthYear {

	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		System.out.print("请输入月份:");
		int month=scanner.nextInt();
		System.out.print("请输入年份:");
		int year=scanner.nextInt();
		int day=0;
		switch(month) {
		case 1:;case 3:;case 5:;case 8:;case 10:;case 12:;
		day=31;break;
		case 4:;case 6:;case 9:;case 11:;
		day=30;break;
		case 2:day=(year%4==0&&year%100!=0||year%400==0)?29:28;
		break;
		}
		System.out.println(day+"天");
	}

}

结果如下:

实验2:公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类的nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

代码如下:

import java.util.Scanner;
public class IDnember {

	public static void main(String[] args) {
		Scanner linescanner=new Scanner(System.in);
		System.out.print("请输入您的身份证件号:");
		String IDNember=linescanner.nextLine();
		String year=IDNember.substring(6,10);
		String month=IDNember.substring(10,12);
		String day=IDNember.substring(12,14);
		System.out.println("你的生日是:"+year+"-"+month+"-"+day+"");
	}

}

  输出结果如下:

      

实验3:studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

(1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

(2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

package studentfile;
import java.io.BufferedReader;
import java.io.File;
import java.io.FileReader;
import java.io.IOException;
import java.util.ArrayList;
import java.util.Scanner;

public class Student{
	private static ArrayList<Student>studentList  = null;
        public static void StudentsFromFile(String fileName){
  	
        File file = new File(fileName);  
        BufferedReader reader = null;  
        try {  
            reader = new BufferedReader(new FileReader(file));  
            String tempString = null;  
            while ((tempString = reader.readLine()) != null) {  
                String str[] = tempString.split(" ");
              if(studentList!= null && str.length > 1) {
                  Student student = new Student();
                  ((Object) student).setStudentId(str[0]);
                  ((Object) student).setName(str[1]);
                  studentList.add(student);
               }
            }  
            reader.close();  
        } catch (IOException e) {  
           e.printStackTrace();  
       } finally {  
            if (reader != null) {  
                try {  
                    reader.close();  
                } catch (IOException e1) {  
                }  
            }  
        } 
    }
public static String NamefindID(String name) {
        String studentId = null;
        for(Student student : studentList) {
            if(((File) student).getName().equals(name)) {
                studentId = ((Object) student).getStudentId();
                break;
            }
        }
        return studentId;
    }
public static String IdfindName(String ID) {
        String studentName = null;
        for(Student student : studentList) {
            if(((Object) student).getStudentId().equals(ID)) {
                studentName = (String) ((File) student).getName();
                break;
            }
        }
        return studentName;
    }
    public static void main(String args[]) {
        String path = "E:\\studentfile.txt";
      studentList = new ArrayList<Student>();
        StudentsFromFile(path);
        int statu = 1;
        System.out.println();
        while(statu != 0) {
            Scanner in = new Scanner(System.in);
            statu = in.nextInt();
            switch(statu) {
            case 1:{                  
            	System.out.println("请输入学生姓名:");
                Scanner scanner1 = new Scanner(System.in);
                String name = scanner1.nextLine();
                String Id = NamefindID(name);
                if(Id != null) {
                    System.out.println("姓名: "+name+" 学号: "+Id);
                }
            }break;
            case 2:{
                System.out.println("请输入学生学号:");
                Scanner scanner2 = new Scanner(System.in);
                String Id = scanner2.nextLine();
                String name = IdfindName(Id);
                if(name != null) {
                    System.out.println("姓名: "+name+" 学号: "+Id);
               }
           }break;
           }
        }        
    }
 }

  输出结果错误

实验总结:通过这周的实验内容,我在测试中发现我对于这一张的学习内容还是没有掌握熟练,对于Scanner类的使用还是不够熟练,在做编程题时花费时间太多,在做第二题时对于Switch的用法出现了错误,导致花费了大量时间。其次,由于对于所学知识还没有完全熟练的掌握,导致我对实验三无法正确的输出结果,我会继续查找自己的错误。也会更加深入的学习,不断地改正自己。

猜你喜欢

转载自www.cnblogs.com/Weiron/p/9657485.html