POJ 1966 Cable TV NETWORK(网络流-最小点割集)

                                        Cable TV NETWORK
The interconnection of the relays in a cable TV network is bi-directional. The network is connected if there is at least one interconnection path between each pair of relays present in the network. Otherwise the network is disconnected. An empty network or a network with a single relay is considered connected. The safety factor f of a network with n relays is: 
1. n, if the net remains connected regardless the number of relays removed from the net. 
2. The minimal number of relays that disconnect the network when removed. 

For example, consider the nets from figure 1, where the circles mark the relays and the solid lines correspond to interconnection cables. The network (a) is connected regardless the number of relays that are removed and, according to rule (1), f=n=3. The network (b) is disconnected when 0 relays are removed, hence f=0 by rule (2). The network (c) is disconnected when the relays 1 and 2 or 1 and 3 are removed. The safety factor is 2.

Input

Write a program that reads several data sets from the standard input and computes the safety factor for the cable networks encoded by the data sets. Each data set starts with two integers: 0<=n<=50,the number of relays in the net, and m, the number of cables in the net. Follow m data pairs (u,v), u < v, where u and v are relay identifiers (integers in the range 0..n-1). The pair (u,v) designates the cable that interconnects the relays u and v. The pairs may occur in any order.Except the (u,v) pairs, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set, the program prints on the standard output, from the beginning of a line, the safety factor of the encoded net.

Sample Input

0 0
1 0
3 3 (0,1) (0,2) (1,2)
2 0
5 7 (0,1) (0,2) (1,3) (1,2) (1,4) (2,3) (3,4)

Sample Output

0
1
3
0
2

Hint

The first data set encodes an empty network, the second data set corresponds to a network with a single relay, and the following three data sets encode the nets shown in figure 1.
题意:给你N个点,以及M个关系,让你求最少去掉多少个点才能使得其中两个点补连通;
题解:最小点割集; 没个点只能去掉一次,因此我们可将每一个点拆分为两个点中间用一条边权为1的边连接(表示只能经过一次,也就是改点只能去掉一次),然后对于其他相连得
两个点U,V: 我们将它们分别分成两个点后U1,U2,V1,V2,建立U1,V2,和V1,U2且其权值为INF(表示可以走无数次),然后根据题意,任意两点无法连通即可;这就转化为
求最小割的问题,最小割==最大流;即求任意不同且不相邻的两点间的最大流,然后取最小的即可;
参考代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<cmath>
#include<vector>
#include<map>
#include<set>
using namespace std;
#define PI acos(-1.0)
#define eps 1e-8
#define mem(a,b) memset(a,b,sizeof a)
typedef long long LL;
typedef pair<int,int> P;
const int INF=0x3f3f3f3f;
const int maxn=2010;
int n,m,s,t,u,v,tot;
struct Edge{
	int from,to,cap,flow;
	Edge(int _f,int _t,int _c,int _fl):from(_f),to(_t),cap(_c),flow(_fl) {}
};
vector<Edge> edges;
vector<int> G[maxn];
bool vis[maxn];
int d[maxn],cur[maxn],flag[210][210];

void Init()
{
	mem(d,0); tot=0;
	for(int i=0;i<=2*n+2;i++) G[i].clear();
}

void Addedge(int from,int to,int cap)
{
	edges.push_back(Edge(from,to,cap,0));
	edges.push_back(Edge(to,from,0,0));
	int m=edges.size();
	G[from].push_back(m-2); G[to].push_back(m-1);
}

bool bfs() 
{
    memset(vis,0,sizeof vis);
    queue<int> q;
    q.push(s);
    d[s] = 0; vis[s] = 1;
    while (!q.empty()) 
	{
        int x = q.front(); q.pop();
        for(int i = 0; i < G[x].size(); ++i) 
		{
            Edge &e = edges[G[x][i]];
            if (!vis[e.to] && e.cap > e.flow) 
			{
                vis[e.to] = 1;
                d[e.to] = d[x] + 1;
                q.push(e.to);
            }
        }
    }
    return vis[t];
}

int dfs(int x,int a) 
{
    if(x == t || a == 0) return a;
    int flow = 0, f;
    for(int &i = cur[x]; i < G[x].size(); ++i) 
	{
        Edge &e = edges[G[x][i]];
        if (d[e.to] == d[x] + 1 && (f=dfs(e.to, min(a, e.cap-e.flow))) > 0) 
		{
            e.flow += f;
            edges[G[x][i]^1].flow -= f;
            flow += f; a -= f;
            if (a == 0) break;
        }
    }
    return flow;
}

int Maxflow(int s, int t) 
{
    int flow = 0;
    while (bfs()) 
	{
        memset(cur,0,sizeof cur);
        flow += dfs(s, INF);
    }
    return flow;
}

struct Node{
	int u,v;
} edg[maxn];

int build(int u,int v)
{
	Init();
	s=u+n; t=v;
	for(int i=1;i<=n;++i) Addedge(i,i+n,1);
	for(int i=0;i<m;i++)
	{
		Addedge(edg[i].u+n,edg[i].v,INF);
		Addedge(edg[i].v+n,edg[i].u,INF);
	}
	return Maxflow(s,t);
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(!m)
		{
			if(n==1) puts("1");
			else puts("0");
			continue; 
		}
		mem(flag,0);
		for(int i=0;i<m;++i)
        {
            scanf(" (%d,%d)", &edg[i].u, &edg[i].v);
            edg[i].u++; edg[i].v++;
            flag[edg[i].u][edg[i].v]=flag[edg[i].v][edg[i].u]=1;
        }
		int ans=INF;
		for(int i=1;i<n;++i)
            for(int j=i+1;j<=n;++j)
                if(!flag[i][j]) ans=min(ans,build(i,j));
		ans=min(ans,n);
		printf("%d\n",ans);
	}
	return 0;	
} 

  

猜你喜欢

转载自www.cnblogs.com/songorz/p/9649427.html
今日推荐