1033 To Fill or Not to Fill

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C~max~ (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; D~avg~ (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P~i~, the unit gas price, and D~i~ (<=D), the distance between this station and Hangzhou, for i=1,…N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:

749.17
Sample Input 2:

50 1300 12 2
7.10 0
7.00 600
Sample Output 2:

The maximum travel distance = 1200.00

分析参考请点击此链接
本题非常有意思,运用贪心的思想。在下一段路程中,加油站分三种情况
1、不存在加油站。
2、加油站的油价都高于当前加油站的价格。
3、存在价格更低的加油站。

参考代码(代码来自别处,注释为本人所加)

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int inf = 99999999;
struct station {
    double price, dis;
};
bool cmp1(station a, station b) {
    return a.dis < b.dis;
}
int main() {
    double cmax, d, davg;
    int n;
    scanf("%lf%lf%lf%d", &cmax, &d, &davg, &n);
    vector<station> sta(n + 1);
    sta[0] = { 0.0, d };
    for (int i = 1; i <= n; i++)
        scanf("%lf%lf", &sta[i].price, &sta[i].dis);
    sort(sta.begin(), sta.end(), cmp1);
    double nowdis = 0.0, maxdis = 0.0, nowprice = 0.0, totalPrice = 0.0, leftdis = 0.0;
    if (sta[0].dis != 0) {
        printf("The maximum travel distance = 0.00");
        return 0;
    }
    else {
        nowprice = sta[0].price;
    }
    while (nowdis < d) {
        maxdis = nowdis + cmax * davg;
        //没找到更便宜的,记录查找的那段路中最便宜的油价,及相应的距离
        double minPriceDis = 0, minPrice = inf;
        int flag = 0;

        for (int i = 1; i <= n && sta[i].dis <= maxdis; i++) {
            if (sta[i].dis <= nowdis) continue;
            //找到更便宜的油
            if (sta[i].price < nowprice) {
                //要加的油量,刚好到那个油价更便宜的地方
                totalPrice += (sta[i].dis - nowdis - leftdis) * nowprice / davg;
                //到新地方后,没油了,若不加油,不能继续前进,因此设置leftdis=0.0
                leftdis = 0.0;
                nowprice = sta[i].price;
                nowdis = sta[i].dis;
                flag = 1;
                break;
            }
            if (sta[i].price < minPrice) {
                minPrice = sta[i].price;
                minPriceDis = sta[i].dis;
            }
        }
        //没找到更便宜油(相比nowprice而言),
        if (flag == 0 && minPrice != inf) {
            //加满油,cmax-leftdis/davg为剩余油量
            totalPrice += (nowprice * (cmax - leftdis / davg));
            //不管在什么地方加完油,都需要设置nowprice,nowdis,leftdis的值
            leftdis = cmax * davg - (minPriceDis - nowdis);
            nowprice = minPrice;
            nowdis = minPriceDis;
        }
        //接下来一段路没有加油站,只好在此处加满油,尽可能开到最远处
        if (flag == 0 && minPrice == inf) {
            nowdis += cmax * davg;
            printf("The maximum travel distance = %.2f", nowdis);
            return 0;
        }
    }
    printf("%.2f", totalPrice);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81777659
今日推荐