PAT A 1033 To Fill or Not to Fill

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C~max~ (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; D~avg~ (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P~i~, the unit gas price, and D~i~ (<=D), the distance between this station and Hangzhou, for i=1,…N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

数学分析的难度大于代码的难度。。。。只是照着晴神的代码理了一遍。。

#include<cstdio>
#include<algorithm>
using namespace std;

struct station {
    double dis, price;
}st[510];

bool cmp(station a, station b) {
    return a.dis < b.dis;
}
int main() {
    double Cmax, D, Davg;
    int N;
    scanf("%lf %lf %lf %d", &Cmax, &D, &Davg, &N);
    for (int i = 0; i < N; i++) {
        scanf("%lf %lf", &st[i].price, &st[i].dis);
    }
    st[N].price = 0, st[N].dis = D;
    sort(st, st + N, cmp);
    if (st[0].dis != 0) printf("The maximum travel distance = 0.00\n");
    else {
        int now = 0;
        double Max = Cmax * Davg, nowtank = 0, ans = 0, need;
        while (now < N) {
            double priceMin = 100;
            int k, i;
            for ( i = now + 1;i <= N && st[i].dis - st[now].dis <= Max; i++) {
                if (st[i].price < priceMin) {
                    priceMin = st[i].price;
                    k = i;
                }
                if (priceMin < st[now].price)break;
            }
            if (priceMin == 100) break;
            need = (st[k].dis - st[now].dis) / Davg;
            if (priceMin < st[now].price) {
                if (nowtank > need) {
                    nowtank -= need;
                }
                else {
                    ans += (need - nowtank) * st[now].price;
                    nowtank = 0;
                }
            }
            else {
                ans += (Cmax-nowtank) * st[now].price;
                nowtank = Cmax - need;
            }
            now = k;
        }
        if(now==N)  printf("%.2f\n", ans);
        else printf("The maximum travel distance = %.2f\n", st[now].dis + Max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80698195
今日推荐