【PAT】A1033. To Fill or Not to Fill (25)

Description:
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,…N. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000

6.85 300


Sample Output 1:

749.17


Sample Input 2:
50 1300 12 2
7.10 0

7.00 600


Sample Output 2:

The maximum travel distance = 1200.00

//NKW 甲级真题1047
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const int maxn = 510;
const int INF = 1000000000;
typedef struct station{
	double p, dis;
}station;
station s[maxn];
bool cmp(station a, station b){
	return a.dis < b.dis;
}
int main(){
	double cmax, d, davg;
	int n;
	scanf("%lf %lf %lf %d", &cmax, &d, &davg, &n);
	for (int i = 0; i < n; i++)
		scanf("%lf %lf", &s[i].p, &s[i].dis);
	s[n].dis = d;
	s[n].p = 0;
	sort(s, s + n, cmp);
	if (s[0].dis != 0){
		printf("The maximum travel distance =0.00\n");
		system("pause");
		return 0;
	}
	int stnow = 0;
	double totalprice = 0, nowtank = 0, maxgo = cmax*davg;;
	while (stnow < n){
		double minprice = INF;
		int stemp = -1;
		for (int i = stnow + 1; i < n + 1 && (s[i].dis - s[stnow].dis) <= maxgo; i++){
			if (s[i].p < minprice){
				minprice = s[i].p;
				stemp = i;
				if (s[i].p < s[stnow].p) break;
			}
		}
		if (stemp == -1)	break;
		double need = (s[stemp].dis - s[stnow].dis) / davg;
		if (s[stnow].p > minprice){
			if (need > nowtank){
				totalprice += (need - nowtank)*s[stnow].p;
				nowtank = 0;
			}
			else
				nowtank -= need;
		}
		else{
			totalprice += (cmax - nowtank)*s[stnow].p;
			nowtank = cmax - need;
		}
		stnow = stemp;
	}
	if (stnow == n)
		printf("%.2f\n", totalprice);
	else
		printf("The maximum travel distance = %.2f\n", s[stnow].dis + maxgo);
	system("pause");
	return 0;
}
以后输出就直接复制题目的吧。。。

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80957566