1032 Sharing (25)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

\ Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意:给出一些节点的地址和只想下一个节点的地址, 找出两条链表第一个公共节点
思路:用vector<int> v来保存当前节点的下一个节点, 用vector<int> v1来记录第一条链表中有哪些节点; 然后遍历第二条链表, 如果节点在v1中有记录就表示该点为公共节点
注意点:在设计到数组下表的时候,一定要先判断下表是否大于0; 再引用数组
#include<iostream>
#include<vector>
using namespace std;

int main(){
  int roota, rootb, n, i;
  cin>>roota>>rootb>>n;
  int addr, next;
  char ch;
  vector<int> v(100000), v1(100000, -1);
  for(i=0; i<n; i++){
    scanf("%d %c %d", &addr, &ch, &next);
    v[addr]=next;
  }
  while(true){
    if(roota==-1) break;
    v1[roota] = 1;
    roota=v[roota];
  }
  bool flag=true;
  while(true){
    if(rootb==-1) break;
    if(v1[rootb]==1){printf("%05d\n", rootb); flag=false; break;}
    rootb=v[rootb];
  }
  if(flag) cout<<"-1"<<endl;
  return 0;
}
#include<iostream>
#include<vector>
using namespace std;

int main(){
  int roota, rootb, n, i;
  cin>>roota>>rootb>>n;
  int addr, next;
  char ch;
  vector<int> v(100000), v1(100000, -1);
  for(i=0; i<n; i++){
    scanf("%d %c %d", &addr, &ch, &next);
    v[addr]=next;
  }
  while(true){
    if(roota==-1) break;
    v1[roota] = 1;
    roota=v[roota];
  }
  bool flag=true;
  while(true){
    if(rootb==-1) break;
    if(v1[rootb]==1){printf("%05d\n", rootb); flag=false; break;}
    rootb=v[rootb];
  }
  if(flag) cout<<"-1"<<endl;
  return 0;
}

猜你喜欢

转载自www.cnblogs.com/mr-stn/p/9166126.html
今日推荐