HDU5890 Eighty seven 预处理+背包 + bitset优化

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tawn0000/article/details/82259936
 

                                        Eighty seven

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1782    Accepted Submission(s): 562


 

Problem Description

Mr. Fib is a mathematics teacher of a primary school. In the next lesson, he is planning to teach children how to add numbers up. Before the class, he will prepare N cards with numbers. The number on the i-th card is ai. In class, each turn he will remove no more than 3 cards and let students choose any ten cards, the sum of the numbers on which is 87. After each turn the removed cards will be put back to their position. Now, he wants to know if there is at least one solution of each turn. Can you help him?

 

Input

The first line of input contains an integer t (t≤5), the number of test cases. t test cases follow.
For each test case, the first line consists an integer N(N≤50).
The second line contains N non-negative integers a1,a2,...,aN. The i-th number represents the number on the i-th card. The third line consists an integer Q(Q≤100000). Each line of the next Q lines contains three integers i,j,k, representing Mr.Fib will remove the i-th, j-th, and k-th cards in this turn. A question may degenerate while i=j, i=k or j=k.

 

Output

For each turn of each case, output 'Yes' if there exists at least one solution, otherwise output 'No'.

 

Sample Input

 

1 12 1 2 3 4 5 6 7 8 9 42 21 22 10 1 2 3 3 4 5 2 3 2 10 10 10 10 11 11 10 1 1 1 2 10 1 11 12 1 10 10 11 11 12

 

Sample Output

 

No No No Yes No Yes No No Yes Yes

 

Source

2016 ACM/ICPC Asia Regional Qingdao Online

首先先预处理所有情况

然后用bitset <90> dp[11] 进行二维背包dp  dp[i][j] 为1 代表在取i个数时能加和到 j ;

bitset 用法

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
#include <map>
#include <bitset>

using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 508 + 10;
const int maxm = 10000 + 10;
typedef pair<int,int> P;
typedef long long LL;
int n,Q;
int a[maxn];

bitset<90> dp[11];
bool ans[55][55][55];

bool check(int x,int y, int z)
{
  for(int i = 0; i < 11; i++)
    dp[i].reset();
  dp[0][0] = 1;
  for(int i = 1; i <= n; i++)
     {
       if(i != x && i != y && i != z)
       for(int j = 9; j >= 0; j--)
          dp[j+1] |= (dp[j] << a[i]);
     }
  if(dp[10][87] == 1) return true;
  else return false;
}

int main()
{
  int T;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d",&n);
    for(int i = 1; i <= n; i++) scanf("%d",&a[i]);
    memset(ans,false,sizeof(ans));
    for(int i = 1; i <= n; i++)
      for(int j = i; j <= n; j++)
        for(int k = j; k <= n; k++)
          {
            if(check(i,j,k))
            {
              ans[i][j][k] = ans[i][k][j] = true;
              ans[j][i][k] = ans[j][k][i] = true;
              ans[k][i][j] = ans[k][j][i] = true;
            }
          }
    scanf("%d",&Q);
    while(Q--)
    {
      int i,j,k;
      scanf("%d%d%d",&i,&j,&k);
      if(ans[i][j][k])
        printf("Yes\n");
      else printf("No\n");
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Tawn0000/article/details/82259936
今日推荐