HDU-Ignatius and the Princess II

Ignatius and the Princess II

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
Can you help Ignatius to solve this problem? 
InputThe input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 
OutputFor each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
思路:考察对头文件 <algorithm>里的 next_permutation(*start,*last)函数的应用。

该函数生成指定容器的下一次排列。容器包括数组,vector,字符串,set,map等。

其中start是要进行下一次排列容器的起始地址,若为数组则直接传入数组名,若是STL模板的容器则用v.begin()来得到第一个元素的地址,last即最后一个元素的地址,若为数组直接传入 数组名+数组大小

比如:

a[3]={1,2,3};
next_permutation(a,a+3);
执行完这两条语句后,a的内容变为1,3,2.

若要穷举某串数字的各种排列,使用next_permutation之前可调用sort先对其进行排序,在逐次调用next_permutation.

与next_permutation函数对应的还有一个pre_permutation上一次排列,用法相同。

题目中的第m大的连续子串即只要对1-n的连续串进行m-1次下一次排列即可。

代码:

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int num[1001];
int main() {
	int m, n;
	while (~scanf("%d%d", &n, &m)) {
		for (int i = 0; i < n; i++)
			num[i] = i + 1;
		for (int i = 1; i < m; i++)
			next_permutation(num,num+n);
		for (int i=0;i<n;i++)
			printf("%d%c",num[i],i==n-1? '\n' : ' ');
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Titanium_S/article/details/79198786
今日推荐