CSU暑期集训day01_G_Ignatius and the Princess II

题目:

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
Can you help Ignatius to solve this problem? 

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 

Sample Input

6    4

11   8

Sample Output

1   2   3   5   6   4  

1   2   3   4   5   6   7   9   8   11   10   

题目大意:

    输入的第一个数n表示有1到n共n个数,从1由小到大排到n的排列是最小排列,最后两个数互换位置的话是倒数第二小的排列,输入的第二个数k要求求出n个数的第k小排列。

解题思路:

    用next_permutation函数,该函数每执行一次可以将数组排序变成比原本大1的排列,用该函数执行k次即可。

代码:

#include <iostream>
#include <algorithm>

using namespace std;

int main(){
    int n,m;
    while(cin>>n>>m){
        int a[1000]={'\0'};
        for(int i=0;i<n;i++){
            a[i]=i+1;
        }    
        for(int j=0;j<m-1;j++){
            next_permutation(a,a+n);
        }
        cout<<a[0];
        for(int k=1;k<n;k++){
            cout<<' '<<a[k];
        }
        cout<<endl; 
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42774699/article/details/81174405