HDU1027(Ignatius and the Princess II)

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5830    Accepted Submission(s): 3439


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
 
  
6 4 11 8
 

Sample Output
 
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

 

题意:给定n,若1,2,3,...n,为最小序列,确定第m小的排序序列并输出。

思路:一个比较笨的方法,找规律。注意1<=M<=10000。

可以发现,一共是n!个序列,那么对于后now位,其共有now!个序列,然后按照这个规律,第一次找到now!>=  m,确定p值,然后累加(now - 1)!,直到计数count + k*(now - 1)! >=m,确定k值,然后找在后p位中,第k大的值,这个值即是从后往前数第p位的值,依次类推,直到确定最后一个值。


#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int rec[15], tmp[15], INF = 1<<28;
int main(){
    int n, m;
    while(~scanf("%d %d",&n, &m)){
        int t = 1, i, now, cur = 0;
        for(i = 1; i <= 10; i++){
            t *= i;
            tmp[i] = t;
            rec[i] = n - i + 1;
            if(t >= m)break;
        }
        now = i;
        sort(rec+1, rec+now+1);
        for(i = 1; i <= n - now; i++)printf("%d ",i);
        while(now > 1){
            int temp = cur;
            while(cur+tmp[now-1] < m){
                cur += tmp[now-1];
            }
            int _ = (cur-temp)/tmp[now-1]+1;
            printf("%d ",rec[_]);
            rec[_] = INF;
            sort(rec+1, rec+now+1);
            now--;
        }
        printf("%d\n",rec[1]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/Mad_boys/article/details/48199523