Ignatius and the Princess II

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10018    Accepted Submission(s): 5839


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
 
  
6 4 11 8
 

Sample Output
 
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

题意:从1到n排序的数,求第m个全排列。

用STL 里 int 下的next_permutation(从小到大全排列)函数即可,每用一次数组中的值就会改变

该函数返回值为bool类型,如果还有下一个全排列返回true,否则返回false

对应的是prev_permutation

#include <iostream>

#include <algorithm>
using namespace std;
int main()
{
int n,m;
int a[1005]; 
while(cin>>n>>m)
  {
  for(int i=1;i<=n;i++)
     a[i]=i;
  for(int i=1;i<m;i++)
     next_permutation(a+1,a+n+1);
  for(int i=1;i<=n;i++)
   if(i==n)
cout<<a[i]<<endl;
else cout<<a[i]<<" ";       
  } 
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41603898/article/details/80260912
今日推荐