A - 2016湖南省赛 -CSU - 1803 -csdn博客

给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:
1. 1≤a≤n,1≤b≤m;
2. a×b 是 2016 的倍数。
Input

输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤10 9).
Output
对于每组数据,输出一个整数表示满足条件的数量。
Sample Input
32 63
2016 2016
1000000000 1000000000
Sample Output
1
30576
7523146895502644

  • 题解:
    根据同余定理:
    (a*b)%p =((a%p)*(b%p))%p
    所以
    (a*b)%2016=((a%2016)*(b%2016))%2016
    此时就把范围缩小到了2016以内。
    因此只要求出n,m在模2016后对应的值a[i],b[i]分别有多少个即可

  • 这里要注意:由于n,m不能为0,所以a[0], b[0]均要少一个1.

#include<bits/stdc++.h>
#define endl '\n'
#define pb push_back
#define mp make_pair
#define _ ios::sync_with_stdio(false)
bool SUBMIT = 1;
typedef long long ll;
using namespace std;
const double PI = acos(-1);
ll a[2016],b[2016];
int main()
{
    if(!SUBMIT)freopen("i.txt","r",stdin);else _;
    ll n,m;
    while(cin>>n>>m)
    {
        ll h=n/2016,g=n%2016;
        for(int i=0;i<2016;i++)
        {
            a[i]=h;
            if(i<=g&&i)a[i]++;
        }
        h=m/2016,g=m%2016;
        for(int i=0;i<2016;i++)
        {
            b[i]=h;
            if(i<=g&&i)b[i]++;
        }
        ll ans=0;
        for(int i=0;i<2016;i++)
            for(int j=0;j<2016;j++)
                if((i*j)%2016==0)
                    ans+=a[i]*b[j];
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38701476/article/details/82502082