2018CCPC网络赛 find interge(D)

http://acm.hdu.edu.cn/showproblem.php?pid=6441

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that a^n +b^n=c^n .

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

Sample Input

 

1 2 3

Sample Output

 

4 5

根据费马大定理可知a^n+b^n=c^n,当n>2时,等式不成立,

所以只需要分析n=1和n=2的情况,

n=1,只需让b=1,c=a+b,即可,

n=2,根据费马大定理奇偶数列法则可知

当a为>=3的奇数时,a=2*n+1,   c=n^2+(n+1)^2,  b=c-1;

当a为>=4的偶数时,a=2*n+2,   c=(n+1)^2+1,    b=c-2;

Ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int a,n;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
            scanf("%d%d",&n,&a);
            int b,c;
       if(n==2)
       {
           if(a>=3&&a%2==1)
           {
               int p=(a-1)/2;
               c=p*p+(p+1)*(p+1);
               b=c-1;
           }
           if(a>=4&&a%2==0)
           {
               int p=(a-2)/2;
               c=(p+1)*(p+1)+1;
               b=c-2;
           }
       }
       else if(n==1)
       {
           b=1;
           c=b+a;
       }
       else {
        b=-1;
        c=-1;
       }
       printf("%d %d\n",b,c);
    }
}

猜你喜欢

转载自blog.csdn.net/curry___/article/details/82082496
今日推荐