How many integers can you find HDU - 1796

版权声明:本文为博主瞎写的,请随便转载 https://blog.csdn.net/sdut_jk17_zhangming/article/details/81949769

 Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
#define MOD 1000000007
typedef long long ll;
//判断1-n有多少个M个因子任一个的倍数
int n,m,cnt;
ll ans ,a[30];
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}

void DFS(int cur,ll lcm,int id)  
{// 当前第几个因子  这些因子的最小共公倍数 当前总因子
    lcm = a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)   //奇加偶减
        ans += (n-1)/lcm;
    else
        ans -= (n-1)/lcm;
    for(int i= cur+1;i<cnt;i++)
        DFS(i,lcm,id+1);
}
int main()
{
    while(scanf("%d%d",&n,&m) != EOF)
    {
        cnt = 0;
        int x;
        while(m--)
        {
            scanf("%d",&x);
            if(x!=0)
                a[cnt++] = x;
        }
        ans = 0;
        for(int i=0;i<cnt;i++) //遍历每种组合 从1开始
            DFS(i,a[i],1);
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdut_jk17_zhangming/article/details/81949769
今日推荐