Dungeon Master--(三维的BFS)

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题目大意:

 相当于一栋大楼里面很多秘密通道,S是起始位置,E是终点位置,‘#’是墙,‘.’是路,问从S出发最少经过多长时间就到达E处;

分析:

和迷宫不同的是,迷宫是平面上东南西北的移动,相当于在大楼里面的一层楼里找出口,而这个题目在迷宫的基础上又增加了上下的移动,即大楼里面的上下层之间的移动, 所以需要建立三维的数组,找到S的位置,移动方向由4个增加到6个,直到找到E为止,如果找遍了所有的能走的地方都没找到出口E,就出不来了!!!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int N = 35;
int l, r, c;
int next1[6] = {-1, 1, 0, 0, 0, 0};//三维坐标就是这样走
int next2[6] = {0, 0, 1, -1, 0, 0};
int next3[6] = {0, 0, 0, 0, 1, -1};
char mapp[N][N][N];
int ans;
struct node
{
    int x;
    int y;
    int z;
    int step;
} f, t;
int pd(int dz, int dx, int dy)//判断是否还在合法区间内。
{
    if(dz<0||dz>=l||dx<0||dx>=r||dy<0||dy>=c||mapp[dz][dx][dy]=='#')
        return 0;
    return 1;
}
int bfs(int az, int ax, int ay)//同一般的BFS一样。
{
    queue <node> q;
    f.x = ax;
    f.y = ay;
    f.z = az;
    f.step = 0;
    q.push(f);
    while(!q.empty())
    {
        f = q.front();
        q.pop();
        int bx = f.x;
        int by = f.y;
        int bz = f.z;
        int i;
        ans = f.step;
        for(i=0; i<6; i++)
        {
            int dx = bx + next1[i];
            int dy = by + next2[i];
            int dz = bz + next3[i];
            if(pd(dz, dx, dy))
            {
                if(mapp[dz][dx][dy]=='E')
                    return ans+1;
                t.x = dx;
                t.y = dy;
                t.z = dz;
                t.step = ans + 1;
                q.push(t);
                mapp[t.z][t.x][t.y] = '#';
            }
        }
    }
    return 0;
}
int main()
{
    int a, b, d, i, j, k;
    while(~scanf("%d%d%d", &l, &r, &c) &&l&&r&&c)
    {
        for(i=0; i<l; i++)
        {
            for(j=0; j<r; j++)
            {
                scanf("%s", mapp[i][j]);//同二维数组一样,mapp[i][j]表示相应的地址。
                for(k=0; k<c; k++)
                {
                    if(mapp[i][j][k]=='S')//记录起始点。
                    {
                        a = i;
                        b = j;
                        d = k;
                    }
                }
            }
        }
        ans = bfs(a, b, d);
        if(ans)
            printf("Escaped in %d minute(s).\n", ans);
        else
            printf("Trapped!\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42137874/article/details/82191081
今日推荐