Knight Moves

题目描述

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

输入

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

输出

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

样例输入

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

样例输出

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<queue>  
using namespace std;  
int map[10][10];  
int fx,fy,lx,ly;  
char a[3],b[3];  
struct node  
{  
    int x,y,num;  
};  
int d[8][2]={-2,1, -1,2, 1,2, 2,1, 2,-1, 1,-2, -1,-2, -2,-1};//Knight的八个移动方位  
void bfs(int x,int y)  
{  
    int i;  
    node t,p;  
    queue<node> q;  
    t.x=x;t.y=y;t.num=0;  
    memset(map,0,sizeof(map));//每一回合棋盘初始为未被访问状态  
    map[t.x][t.y]=1;  
    q.push(t);  
    while(!q.empty())  
    {  
        t=q.front();q.pop();  
        if(t.x==lx&&t.y==ly)  
        {  
            printf("To get from %s to %s takes %d knight moves.\n",a,b,t.num);  
            return;  
        }  
        for(i=0;i<8;i++)  
        {  
            if((t.x+d[i][0]>0)&&(t.x+d[i][0]<9)&&(t.y+d[i][1]>0) //判断移动是否越界  
                &&(t.y+d[i][1]<9)&&!map[t.x+d[i][0]][t.y+d[i][1]])//和移动的格子是否已被访问  
            {  
                p.x=t.x+d[i][0];  
                p.y=t.y+d[i][1];  
                p.num=t.num+1;  
                q.push(p);  
            }  
        }  
    }  
}  
int main()  
{  
    while(scanf("%s%s",a,b)!=EOF)  
    {  
        fx=a[0]-'a'+1;fy=a[1]-'0';  
        lx=b[0]-'a'+1;ly=b[1]-'0';  
        bfs(fx,fy);  
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/A_I_Q/article/details/82185995