Knight Moves UVA - 439

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the ”difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a..h) representing the column and a digit (1..8) representing the row on the chessboard.

Output

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

分析:很容易想到就是BFS,每走一步就步数加1,这样到达终点后就是最短的步数。

#include <bits/stdc++.h>
using namespace std;
int end_r,end_c,vis[10][10];
int dir[] = {2,1,-1,-2,-2,-1,1,2};
int dic[] = {-1,-2,-2,-1,1,2,2,1};
char s1[5],s2[5];
struct node
{
	int r,c,step;
};
node b;
queue<node> q;
int bfs()
{
	node next,temp;
	while(!q.empty())
	{
		temp = q.front();
		q.pop();
		if(temp.r == end_r&&temp.c == end_c)
			return temp.step;//如果起始点于一点情况 
		for(int i = 0; i < 8; i++)
		{
			next.r=temp.r+dir[i];
			next.c=temp.c+dic[i];
			if(next.r == end_r&&next.c == end_c)
				return temp.step+1; //走到终点输出 最后也有一步没有更新 
			if(next.r<1||next.r>8||next.c<1||next.c>8||vis[next.r][next.c ] != 0)
				continue; //不符合的点 
			vis[next.r][next.c] = 1; //走过的点要舍去 
			next.step =temp.step+1;
			q.push(next); //符合的点就压入 
		}
	}
	return 0;
}
void q_clear()
{
	while(!q.empty())
		q.pop();
}
int main()
{	
	while(~scanf("%s%s",s1,s2))
	{
		q_clear(); //清空队列
		//因为我找到结果就直接输出了没有去清空队列 
		memset(vis,0,sizeof vis);
		b.r = 1+(s1[0]-'a');
		b.c = s1[1]-'0';
		end_r = 1+(s2[0]-'a');
		end_c = s2[1]-'0';
		b.step = 0;
		vis[b.r][b.c] = 1;
		q.push(b);
		printf("To get from %s to %s takes %d knight moves.\n",s1,s2,bfs());
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/81168165