【POJ1915】Knight Moves

                                                      Knight Moves

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 29237   Accepted: 13765

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

解析:

       双向广搜。

       具体来说,就是从起点和终点同时出发进行搜索,两种不同方向的路径交叉的的第一个点即为最短路径,与一般的广搜相比效率更高。

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cctype>
using namespace std;

const int Max=100005;
const int fx[10]={0,-2,-1,1,2,2,1,-1,-2};
const int fy[10]={0,1,2,2,1,-1,-2,-2,-1};
int t,n,sx,sy,tx,ty,head,tail;
struct shu{int x,y;};
shu p[Max];
int vis[305][305],dis[305][305];

inline int bfs()
{
	head=0,tail=2;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	p[1].x=sx,p[1].y=sy,vis[sx][sy]=1;
	p[2].x=tx,p[2].y=ty,vis[tx][ty]=2;
	while(head<tail)
	{
	  int x=p[++head].x,y=p[head].y;
	  for(int i=1;i<=8;i++)
	  {
	  	int xx=x+fx[i],yy=y+fy[i];
	  	if(xx<0||xx>=n||yy<0||yy>=n) continue;
	  	if(vis[xx][yy]&&vis[xx][yy]!=vis[x][y]) return dis[xx][yy]+dis[x][y]+1;
	  	if(!vis[xx][yy])
	  	{
	  	  dis[xx][yy]=dis[x][y]+1;
	  	  vis[xx][yy]=vis[x][y];
	  	  p[++tail].x=xx,p[tail].y=yy;
	  	}
	  }
	}
}

int main()
{
	scanf("%d",&t);
	while(t--)
	{
	  scanf("%d%d%d%d%d",&n,&sx,&sy,&tx,&ty);
	  if(sx==tx&&sy==ty) cout<<"0\n";
	  else cout<<bfs()<<"\n";
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38083668/article/details/81606943
今日推荐