Knight Moves(骑士跳跃—— BFS)

Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the “difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output
For each test case, print one line saying “To get from xx to yy takes n knight moves.”.

Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

/*
一开始理解题意不要太好理解,并不是简单的上下左右搜索
而是 类似于象棋马的走法——走日字,问你几步能到达终点
方向有八个
*/
/*
求最短的步数,用 BFS
与我博客中的 Hero In Maze 类似 
https://blog.csdn.net/JKdd123456/article/details/80245758
*/
/*
思路:输入一个字符串,s[0]是字符,s[1] 是数字
通过转化将 字符和数字都转化成 int 型的数字
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
char s[10],c[10];
int xx[]={-1,1,-1,1,-2,2,-2,2};//定义常量数组找到搜索的点
int yy[]={2,2,-2,-2,1,1,-1,-1};
int vis[10][10]={0};
struct NODE
{
    int x;
    int y;
    int step;
}node,h,data;
int BFS()
{
    queue<NODE>q;
    int i,X,Y;
    node.x=s[0]-96;// a 转化成 1
    node.y=s[1]-48;
    node.step=0;
    X=c[0]-96;
    Y=c[1]-48;
    q.push(node);
    while(!q.empty())
    {
        h=q.front();
        q.pop();
        if(h.x==X&&h.y==Y)
            return h.step;
        for(i=0;i<=7;i++)
        {
            data.x=h.x+xx[i];
            data.y=h.y+yy[i];
            if((data.x>=1&&data.x<=8)&&(data.y>=1&&data.y<=8)&&(!vis[data.x][data.y]))
            {
                vis[data.x][data.y]=1;
                data.step=h.step+1;
                q.push(data);
            }
        }
    }
    return 0;
}
int main()
{
    int n;
    while(~scanf("%s %s",&s,&c))
    {
        memset(vis,0,sizeof(vis));
        n=BFS();
        printf("To get from %s to %s takes %d knight moves.\n",s,c,n);
    }
}

猜你喜欢

转载自blog.csdn.net/jkdd123456/article/details/80273518