Knight Moves(BFS)

版权声明:转载请注明出处链接 https://blog.csdn.net/qq_43408238/article/details/89441313
Total Submissions: 30194   Accepted: 14198

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

常规的最短路径题目,用BFS再好不过了,不过在细节处理上还是费了点力气。

Code

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <queue>
#include <map>
#define ll long long
using namespace std;
ll n,m;
ll dir[][2]={{-2,1},{-2,-1},{-1,2},{-1,-2},{1,2},{1,-2},{2,1},{2,-1}};//八个方向
struct node
{
  ll step,x,y;
  node(ll x1,ll y1,ll sd) {x=x1,y=y1,step=sd;}
};
ll s1,s2,e1,e2,sum,L;queue<node> v;
bool ans[1000][1000];//标记数组
void bfs()
{
    while(!v.empty())
    {
        node q=v.front();v.pop();ans[q.x][q.y]=1;
        if(q.x==e1&&q.y==e2) {sum=q.step;return ;}
        if(sum!=0) return ;
        for(ll i=0;i<8;i++)
        {
            ll a=q.x+dir[i][0],b=q.y+dir[i][1];
            if(a>=0&&a<L&&b>=0&&b<L&&!ans[a][b])//符合条件,添加节点
            {
                v.push(node(a,b,q.step+1));ans[a][b]=1;
            }
        }

    }
}
void init()
{
    while(!v.empty()) v.pop();
}
int main()
{
    //freopen("input.txt","r",stdin);
    ll t;
    cin>>t;
    while(t--)
    {
        init();//清空队列
        cin>>L;
        cin>>s1>>s2>>e1>>e2;
        v.push(node(s1,s2,0));
        sum=0;memset(ans,0,sizeof(ans));
        bfs();
        cout<<sum<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_43408238/article/details/89441313