A1144. The Missing Number

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

#include<iostream>
#include<cstdio>
#include<map>
using namespace std;
map<int,bool>mp;
int main(){
    int N;
    scanf("%d", &N);
    for(int i = 0; i < N; i++){
        int num;
        scanf("%d", &num);
        if(num > 0){
            mp[num] = true;
        }
    }
    for(long long i = 1; i < 1000000000; i++){
        if(mp.count(i) == 0){
            printf("%lld", i);
            break;
        }
    }
    cin >> N;
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/zhuqiwei-blog/p/9569683.html