PAT甲级--1144 The Missing Number(20 分)

1144 The Missing Number(20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

解题思路:这题我一开始绕了弯路,我把那些正数的都存在一个数组,然后排序,看一下相减是不是大于1,真是服了我自己,我后面百度了一下,之前这个方法我经常用的,怎么今天就忘了,哎。直接在所存的数做下标统计一下就好了

#include<bits/stdc++.h>
using namespace std;
int a[100010];
int main(void)
{
	int n;
	scanf("%d",&n);
	memset(a,0,sizeof a);
	for(int i=0;i<n;i++)
	{
		int x;
		scanf("%d",&x);
		if(x>0&&x<100010)
		a[x]++;
	}
	for(int i=1;i<=100010;i++)
	{
		if(a[i]==0)
		{
			cout<<i<<endl; 
			break;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82051584