1144 The Missing Number(20 分)

版权声明: https://blog.csdn.net/ysq96/article/details/81747762

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题意:

给n个数字,找到不在这个数字列表里面的最小的正整数

分析:

题目几个关键词:①正整数②未出现的③范围是int

有了限定,就会好做一点。首先利用map将数字映射到这个数字出现的次数,只要出现过,这个数字必定大于0。再利用一个num从1依次递增开始判断map中对应出现次数是否大于0,否则就是未出现过的

C++:

#include "iostream"
#include "map"
using namespace std;
map<int,int> e;
int main(){
	int n;
	cin>>n;
	for (int i=0;i<n;i++)
	{
		int temp;
		cin>>temp;
		e[temp]++;
	}
	int num=1;
	while (e[num]>0)num++;
	cout<<num<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81747762
今日推荐