PAT 1144 The Missing Number (20 分)

1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

  题意:在给定的数中找出缺失的最小整数

  解题思想:利用数组为给定的数字做标记,最后对数组进行遍历即可。

#include <iostream>
using namespace std;

int main()
{
    int m,k,f[100008],i;
    cin>>m;
    f[100008]= {0};
    for(i=0; i<m; i++)
    {
        cin>>k;
        if(k>0&&k<100008)
        {
            f[k]=1;
        }
    }
    for(i=1; i<=100008; i++)
    {
        if(f[i]==0)
        {
            cout<<i;
            break;
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/wx960421/article/details/86515189
今日推荐