HDU 2196 Computer(树形DP)

任重而道远

Problem Description

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input

5

扫描二维码关注公众号,回复: 2995189 查看本文章

1 1

2 1

3 1

1 1

Sample Output

3

2

3

4

4

AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 1e4 + 10;
struct Edge {
	int tov, nxt, val;
}e[N << 1];
int head[N << 1], fa[N], dp[N][3], son[N];
int num, n;

void add_edge (int u, int v, int val) {
	num++;
	e[num].tov = v;
	e[num].val = val;
	e[num].nxt = head[u];
	head[u] = num;
}

int dfs_1 (int u, int fa) {
	if (dp[u][0] >= 0) return dp[u][0];
	dp[u][0] = dp[u][1] = dp[u][2] = son[u] = 0;
	for (int i = head[u]; i; i = e[i].nxt) {
		int v = e[i].tov;
		if (v == fa) continue;
		if (dp[u][0] < dfs_1 (v, u) + e[i].val) {
			dp[u][1] = dp[u][0];
			dp[u][0] = dfs_1 (v, u) + e[i].val;
			son[u] = v;
		} else if (dp[u][1] < dfs_1 (v, u) + e[i].val)
		    dp[u][1] = dfs_1 (v, u) + e[i].val;
	}
	return dp[u][0];
}

void dfs_2 (int u, int fa) {
	for (int i = head[u]; i; i = e[i].nxt) {
		int v = e[i].tov;
		if (v == fa) continue;
		if (v == son[u])
		  dp[v][2] = max (dp[u][1], dp[u][2]) + e[i].val;
		else 
		  dp[v][2] = max (dp[u][0], dp[u][2]) + e[i].val;
		dfs_2 (v, u);
	}
	return ;
}

void init () {
	num = 0;
	memset (dp, -1, sizeof (dp));
	memset (head, 0, sizeof (head));
	memset (son, -1, sizeof (son));
}

int main () {
	while (cin >> n) {
		init ();
		for (int i = 2; i <= n; i++) {
			int u, len;
			scanf ("%d%d", &u, &len);
			add_edge (u, i, len);
			add_edge (i, u, len);
		}
		dfs_1 (1, -1);
		dfs_2 (1, -1);
		for (int i = 1; i <= n; i++)
		  printf ("%d\n", max (dp[i][0], dp[i][2]));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/INTEGRATOR_37/article/details/81674821