1028 人口普查

1028 人口普查(20 分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N,取值在(0,10​5​​];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

测试点3是当所输入的生日均无效时,应输出0。我写的这一段代码耗时很大,最后一个测试点应该是输入的N非常大,运气好的话可以不超时......真的看运气,提交多次发现测试点四的运行时间在180~200+这个范围......不知道换成c语言的输入输出会不会快一点。

参考代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
struct info {
	string name;
	string born;
};
struct node {
	string nam;
	int y;
	int m;
	int d;
};
bool com(node a, node b)
{
	if (a.y != b.y)
		return a.y <b.y;
	else
	{
		if (a.m != b.m)
			return a.m < b.m;
		else
			return a.d < b.d;
	}
}
int main()
{
	int N;
	cin >> N;
	vector<node>res;
	int year, month, day;
	for (int i = 0; i < N; i++)
	{
		info exa;
		cin >> exa.name >> exa.born;

		year = (exa.born[0] - '0') * 1000 + (exa.born[1] - '0') * 100 + (exa.born[2] - '0') * 10 + (exa.born[3] - '0');
		month = (exa.born[5] - '0') * 10 + (exa.born[6] - '0');
		day = (exa.born[8] - '0') * 10 + (exa.born[9] - '0');
		if (year < 1814 || year>2014)
			continue;
		else if (year == 1814 && month < 9)
			continue;
		else if (year == 1814 && month == 9 && day < 6)
			continue;
		else if (year == 2014 && month > 9)
			continue;
		else if (year == 2014 && month == 9 && day > 6)
			continue;
		else
		{
			node hh;
			hh.nam = exa.name;
			hh.y = year;
			hh.m = month;
			hh.d = day;
			res.push_back(hh);
		}

	}
	if (!res.empty())
	{
		int n = res.size();
		sort(res.begin(), res.end(), com);
		cout << n << " " << res[0].nam << " " << res[res.size() - 1].nam;
	}
	else
		cout << "0";

	return 0;
}

猜你喜欢

转载自blog.csdn.net/wss123wsj/article/details/82013555