POJ 2405 KMP next数组的运用 ʕ •ᴥ•ʔ

Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:求一个字符串的循环节循环了几次

先跑一遍next数组 用数组总长度-nexxt[len] 就是她循环节的长度 然后如果 总长度%循环节!=0 的话 就输出1  举例:abcdab

 需要注意的是不可以定义next数组 因为next好像是变量和int差不多

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#define N 0x3f3f3f3f
#define ll long long
using namespace std;
string s;
int nexxt[1000010];
void getnext()
{
	int i=0,j=-1;
	nexxt[0]=-1;
	int len=s.size();
	while(i<len)
	{
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			nexxt[i]=j;
		}
		else
		j=nexxt[j];
	}
	
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>s)
	{
		if(s==".")
		break;
		getnext();
		int len=s.size();
		int a=len-nexxt[len];
		if(len%a==0)
		printf("%d\n",len/a);
		else
		printf("1\n");
		
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81902836