POJ 2406 Power Strings【KMP--next数组】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/88024016

题目:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 题目大意:

        求一个字符串的最大循环次数。

解题思路:

       next [len] 中存放 截止到第n个字符前缀=后缀的最长长度,如果该字符串存在循环节,len- next [len]就是最小的循环节长度,则循环节长度可以整除 len ;如果不存在循环节,则 len-next [len]< len/2【自己试验一下即可,玄学】,不可能整除 len;

实现代码:

#include<cstdio>
#include<fstream>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
using namespace std;
const int maxn=1e6;
char s[maxn+10];
int next[maxn+10];

void get_next(char s[],int len){
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1||s[i]==s[j]){
            j++; i++; next[i]=j;
        }
        else j=next[j];
    }
}

int main(){
    memset(next,0,sizeof(0));
//假设S的长度为len,则S存在循环子串,
//当且仅当,len可以被len - next[len]整除,
//最短循环子串为S[len - next[len]]
    while(scanf("%s",s),s[0]!='.'){
        int len=strlen(s);
        get_next(s,len);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/88024016