poj2405 Power Strings KMP

Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:

KMP预处理nxt数组存前面的最长前后缀,对于整个字符串来说,如果len % (len - nxt[len - 1]) == 0,那么这个字符串肯定是有周期的并且周期T = len / (len - nxt[len - 1]),于是我们只需要暴力遍历一遍整个字符串就行了;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = (int)1e6 + 10;
char s[maxn];
int nxt[maxn];
void init(int n)
{
	memset(nxt,0,sizeof(nxt));
	nxt[0] = 0;
	int i = 1,j = 0;
	while (i < n)
	{
		if (s[i] == s[j])
			nxt[i ++] = ++ j;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
	}
}
int main()
{
	while (~scanf("%s",s))
	{
		if (!strcmp(s,"."))
			break;
		int len = strlen(s);
		init(len);
		if (len % (len - nxt[len - 1]) == 0)
			printf("%d\n",len / (len - nxt[len - 1]));
		else
			printf("1\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81814399
今日推荐