Poj 3370 Halloween treats -抽屉原理

题目链接:This is the link

Halloween treats

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9370   Accepted: 3351   Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source

Ulm Local 2007

题目大意:给你n,m,和m个数,从m个数里面选取一些数,这些数的和能够整除n,输出这些数的位置

思路:我们计算前缀和,因为题目中的n<m,所以用前缀和对n取余,肯定存在相同余数的情况,(抽屉原理)

这两个前缀和相减,得到的数一定可以整除n,输出中间的位置即可

特殊情况:前n项和直接可以整除的情况要讨论。

可以参考这里:This is the link

This is the code

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include <iomanip>
#include<list>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define MOD 1e9+7
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
const int dr[]={0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]={-1, 1, 0, 0, -1, 1, -1, 1};
// ios.sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了
LL sum[10005];
int v[10005];
int a[10005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        sum[0]=0;
        int temp;
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
            v[i]=-1;//表示没有余数
        }
        v[0]=0;//表示前n项正好相除
        for(int i=1;i<=n;++i)
        {
            int ans=sum[i]%n;
            if(v[ans]!=-1)
            {
                printf("%d\n",(i-v[ans]));
                for(int j=v[ans]+1;j<=i;++j)
                    printf("%d\n",a[j]);
                break;
            }
            v[ans]=i;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdau_fangshifeng/article/details/81660447
今日推荐