Cleaning Shifts POJ - 2376 (贪心题)

Cleaning Shifts
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31194   Accepted: 7677

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
 
题意:几个区间要覆盖所有的区间,问最少的区间个数
题解:排序后贪心,按照开始时间排序,开始时间相同按照结束排
 
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=20005;

int n,t,lst=0,ans;
struct nde
{
    int st,en;
}cw[25005];
bool cmp(nde p,nde q)
{
    if(p.st!=q.st)
        return p.st<q.st;
    return p.en>q.en;
}
int main()
{
    int i,j,k,l,f;
    cin>>n>>t;
    for(i=1;i<=n;i++)
        cin>>cw[i].st>>cw[i].en;
    sort(cw+1,cw+n+1,cmp);
    for(i=1;i<=n;i++)
    {
      //  cout<<lst<<" ";
        f=0;
        if(lst<cw[i].st-1)
        {
            cout<<"-1"<<endl;    //没有连续或者交集的时间段肯定做不完
            return 0;
        }
        for(j=1,k=lst;cw[j].st<=lst+1 && j<=n;j++)
            if(cw[j].en>k)
            {
                k=cw[j].en;
                i=j;
                f=1;
            }
        if(f)
            ans++;
        lst=k;
    }
    if(lst<t)
    {
        cout<<"-1"<<endl;
        return 0;
    }
    cout<<ans<<endl;
}

猜你喜欢

转载自www.cnblogs.com/smallhester/p/9499845.html
今日推荐