Cleaning Shifts POJ - 2376 ——贪心,最少线段覆盖

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output
  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input
    3 10
    1 7
    3 6
    6 10
    Sample Output
    2
    Hint
    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
刚开始是想着吧所有不可能的情况列举出来,但是好像少考虑了什么,后来想起来这个题目做过,就是先排序,在

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const long long mod=1e9+7;
#define ll long long
struct node
{
     int sta;
     int fin;
     bool operator <(const node& a)const
     {
          if(sta==a.sta)
              return fin>a.fin;
          return sta<a.sta;
     }
}e[25005];
int main()
{
     int n,len;
     while(scanf("%d%d",&n,&len)!=EOF)
     {
         for(int i=1;i<=n;i++)
             scanf("%d%d",&e[i].sta,&e[i].fin);
         sort(e+1,e+n+1);
         int ans=1,cover=e[1].fin;
         if(e[1].sta>1)
             printf("-1\n");
         else
         {
          int flag=0;
          int i=2;
          for(;i<=n;)
          {
               int maxn=0;
               while(e[i].sta<=cover+1)
               {
                    maxn=max(maxn,e[i].fin);
                    i++;
               }
               if(maxn==0)
               {
                    flag=1;
                    break;
               }
               if(maxn>cover)
               {
                    cover=maxn;
                    ans++;
               }
               if(maxn>=len)
                    break;
          }
          if(cover<len||flag)
              printf("-1\n");
          else
              printf("%d\n",ans);
         }
     }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/tianyizhicheng/article/details/82011547