poj-2376-Cleaning Shifts

Cleaning Shifts
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29548   Accepted: 7292

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 
题意:农夫打扫卫生,去租牛,现在知道牛工作的开始和结束时间,求农夫最少可以租几头牛才能在给出的时间段内始终有牛在工作,
思路:区间覆盖问题,求在将区间完全覆盖的前提下,是用最少的牛

代码:

#include<map>
#include<stack>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 31000
#define ll long long
struct qq
{
    int start,ends;
} a[maxn];
int cmp(qq A,qq B)
{
    if(A.start==B.start)
        return A.ends>B.ends;
    else
        return A.start<B.start;
}
int main()
{
    int n,t;
    while(scanf("%d%d",&n,&t)!=EOF)
    {
        int i,j,k,ans=1,l=0,r=0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&a[i].start,&a[i].ends);
        }
        sort(a,a+n,cmp);
        int ends1=0;
        l=a[0].start;
        r=a[0].ends;
        for(i=1; i<n; i++)
        {
            if(a[i].start>r+1)
            {
                ans++;
                r=ends1;
            }
            if(a[i].start<=r+1)
            {
                if(a[i].ends>ends1)
                {
                    ends1=a[i].ends;
                }
                if(a[i].ends==t)
                {
                    r=t;
                    ans++;
                    break;
                }
            }
        }
        if(l!=1||r!=t)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81032262