Balanced Lineup(ST)

描述

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

输入

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

输出

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

样例输入

6 3
1
7
3
4
2
5
1 5
4 6
2 2

样例输出

6
3
0

题目大意:

给定一个序列,每次查询一个区间,求这个区间最大值与最小值的差。

#include <bits/stdc++.h>
using namespace std;
const int N=5e4+5;
const int INF=0x3f3f3f3f;
int st1[N][20],st2[N][20],a[N];///st1[i][j]代表以第i个开始长度为2^j的区间内的最大值
int query(int l,int r)
{
    int k=log2(r-l+1);///需要查询的区间长度
    return max(st1[l][k],st1[r-(1<<k)+1][k])-min(st2[l][k],st2[r-(1<<k)+1][k]);///[l][k]以l开始,[r-(1<<k)+1][k]到r结束
}
int main()
{
    int n,m;
    memset(st2,INF,sizeof st2);
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
        st1[i][0]=st2[i][0]=a[i];
    for(int j=1;j<20;j++)
        for(int i=1;i+(1<<(j-1))<=n;i++)
            st1[i][j]=max(st1[i][j-1],st1[i+(1<<(j-1))][j-1]),st2[i][j]=min(st2[i][j-1],st2[i+(1<<(j-1))][j-1]);
    while(m--)
    {
        int l,r;
        scanf("%d%d",&l,&r);
        printf("%d\n",query(l,r));
    }
    return 0;
}

 

猜你喜欢

转载自www.cnblogs.com/zdragon1104/p/9499665.html