Catch That Cow(广度搜索 poj 3278)

Catch That Cow(点击转到

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 119275   Accepted: 37221

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

[Submit]   [Go Back]   [Status]   [Discuss]

1.求最优解,用广搜。

#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,k;
int vis[100010];
struct cow
{
	int x;
	int step;
	cow(int xx,int steps):x(xx),step(steps){}	
};
queue<cow>q;
int main()
{
	cin>>n>>k;
	memset(vis,0,sizeof(vis));
	q.push(cow(n,0));
	vis[n]=1;
	while(!q.empty())
	{
		cow c=q.front();
		if(c.x==k)
		{
			cout<<c.step<<endl;
			return 0;
		}
		else
		{
			if(c.x-1>=0&&!vis[c.x-1])
			{
				q.push(cow(c.x-1,c.step+1));
				vis[c.x-1]=1;
			}
			if(c.x+1<=100000&&!vis[c.x+1])
			{
				q.push(cow(c.x+1,c.step+1));
				vis[c.x+1]=1;
			}
			if(c.x*2<=100000&&!vis[c.x*2])
			{
				q.push(cow(c.x*2,c.step+1));
				vis[c.x*2]=1;
			}
			q.pop();
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SSYITwin/article/details/81805708
今日推荐