Catch That Cow-POJ3278

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 114963   Accepted: 35950

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

思路:很明显的bfs,但是dfs一直卡,正在思考为什么...
代码如下:
#include<iostream>
#include<cstdio>
#include<string.h>
#include<queue>
using namespace std;
struct node{
	int x,y,step;
}pp;
queue<node> q;
int vis[200010];
int n,m;
int bfs()
{
	while(!q.empty()) q.pop();
	memset(vis,0,sizeof(vis));
	vis[pp.x]=1;//标记牧场主开始的位置 
	q.push(pp);
	while(!q.empty()){
		node now=q.front(); 
		if(now.x==m) return now.step;
		q.pop(); 
		for(int i=0;i<3;i++){
			node next=now;
		    if(i==0){
			    next.x-=1;
		    }
		    else if(i==1){
			    next.x+=1;
		    }
		    else if(i==2){
			    next.x*=2;
	 	    }
	 	    next.step++;
	 	    if(next.x==m) return next.step;
	 	    if(next.x>=0&&next.x<=200000&&!vis[next.x]){//判断是否越界 
	 	    	vis[next.x]=1;
				 q.push(next); 
			 }
    	}	
	}

}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF){
		bfs();
		pp.x=n,pp.step=0;
		printf("%d\n",bfs());
	}
}




猜你喜欢

转载自blog.csdn.net/dadaguai001/article/details/81021791