C - Catch That Cow POJ - 3278

C - Catch That Cow

POJ - 3278

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

AC代码

#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<string>
#include<cstdio>
#include<cstring>
#include<sstream>
#include<cstdlib>
#include<cstring>
#include<sstream>
#include<iostream>
#include<algorithm>

using namespace std;
const int maxn = 100500;
const int INF = 0x3f3f3f3f;
const int mod = 7;
typedef long long ll;
#define PI 3.1415927

int n, k;
bool vis[maxn];
int ans;
struct Node
{
    int num;
    int step;
    Node(int _num, int _s){num=_num;step=_s;}
};
void bfs()
{
    queue<Node> que;
    que.push(Node(n, 0));
    vis[n] = true;
    while(que.size())
    {
        Node nn = que.front(); que.pop();
        int nnum = nn.num+1;
        if(0<=nnum&&nnum<maxn&&!vis[nnum])
        {
            if(nnum == k)
            {
                ans = nn.step+1;
                break;
            }
            que.push(Node(nnum, nn.step+1));
            vis[nnum] = true;
        }
        nnum = nn.num-1;
        if(0<=nnum&&nnum<maxn&&!vis[nnum])
        {
            if(nnum == k)
            {
                ans = nn.step+1;
                break;
            }
            que.push(Node(nnum, nn.step+1));
            vis[nnum] = true;
        }
        nnum = nn.num*2;
        if(0<=nnum&&nnum<maxn&&!vis[nnum])
        {
            if(nnum == k)
            {
                ans = nn.step+1;
                break;
            }
            que.push(Node(nnum, nn.step+1));
            vis[nnum] = true;
        }
    }
}
int main()
{
    scanf("%d%d", &n, &k);
    if(n<k)
    {
        bfs();
        printf("%d\n", ans);
    }
    else
    {
        printf("%d", n-k);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/81315492