2018 Multi-University Training Contest 3 1006 Grab The Tree

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 2004 Accepted Submission(s): 911

Problem Description
Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,…,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can’t grab both x and y. After Q’s move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices’ value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

Input
The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,…,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

Output
For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

Sample Input
1
3
2 2 2
1 2
1 3

Sample Output
Q

题意:给你一个无向树,每个点有点权。小Q可以从中任选一些不相邻的点,这些点的异或值若大于剩下的点的异或值,那么输出Q,相等则输出D,否则输出T。
思路:
预备知识:a^a=0
假设取出一堆数异或值为a,剩下所有数的异或值为b,那么如果a^b为0,则两边的值一定相等,若不为0,则比较大小,哪边大 小Q就取哪边,则小Q一定能获胜。
因此就是求a^b 是否为0,其实a^b就等于所有数的异或值,因此把所有数的异或值求出来判断是否为0即可。
其实所给的取不相邻的数这个条件并没有用到,因为异或值不会超过里面的最大值。

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int t;
    int n,sum,u,v,a;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&n);

        for(int i=0; i<n; i++)
        {
            scanf("%d",&a);
            sum^=a;
        }

        for(int i=0; i<n-1; i++)
        {
            scanf("%d%d",&u,&v);
        }

        if(sum==0)
            printf("D\n");
        else
            printf("Q\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42515626/article/details/81395053