2018 Multi-University Training Contest 3 Problem F. Grab The Tree(博弈论&二进制运算)

 Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

Sample Input

1 3 2 2 2 1 2 1 3

Sample Output

Q

对于二进制的运算一直是迷的,本题思路其实也是先手占优,也算个博弈论吧,如果小Q抓位数最多的节点,那么无论如何,异或和都会比小T大(异或和不会增加位数),所以异或运算遍历一遍,如果=0,则平局,其余均是Q赢。

#include <iostream>
#include <cstdio>
#include <set>
#include <cstring>
#define MAXN 100100
using namespace std;
int f[MAXN];
int n, tree[MAXN], x, y, amount[MAXN];
int main()
{
  int t;
  scanf("%d", &t);
  while(t--)
  {
      memset(amount, 0, sizeof(amount));
      scanf("%d", &n);
      
      for(int i = 0; i < n; i++)
      {
          scanf("%d", &tree[i]);
    }
    int sum = tree[0];
    for(int i = 0; i < n-1; i++)
    {
        scanf("%d %d", &x, &y);
    }
    for(int i = 1; i < n; i++)
    {
        sum ^= tree[i];
    }
    if(sum == 0)
        cout << 'D' << endl;
    else
        cout << 'Q' << endl;
  }
}

猜你喜欢

转载自blog.csdn.net/blackmail3/article/details/81316797