HDU 6324 Grab The Tree

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 432    Accepted Submission(s): 298


 

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 

Sample Input

1
3
2 2 2
1 2
1 3

Sample Output

Q

题目大意:给你一棵树,每个节点有一个权值,小Q先拿一些结点,要求拿的节点之间不能有边相邻,小T拿完其他所有结点,问谁会赢

其实和树没什么关系,先将所有结点异或起来,如果==0,则怎么拿双方都是0,平局。若!=0,则对于异或出来的值上的最高位的1,则所有权值中这个位置上的1肯定是个奇数,那只要拿走这个权值,Q就赢了

#include<cstdio>
using namespace std;
int main()
{
	int test;
	scanf("%d",&test);
	while(test--)
	{
		int n;
		scanf("%d",&n);
		int ans=0;
		for(int i=0;i<n;i++)
		{
			int x;
			scanf("%d",&x);
			ans^=x;
		}
		for(int i=0;i<n-1;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
		}
		if(ans==0) puts("D");
		else puts("Q");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37943488/article/details/81302396